babel-preset-es2015-mod

2020-02-14

babel-preset-es2015-mod

Babel preset for all es2015 plugins, plus --loose es6.modules.

dependency status">babel-preset-es2015-mod Dependency Status

Babel preset for all es2015 plugins, modified to enable --loose es6.modules.

The code modifies babel-preset-es2015just a little bit. I had to mix es2015 modules with old-school node modules. This is what I came up with.

Install

NPM

$ npm install --save-dev babel-preset-es2015-mod

Usage

Via .babelrc(Recommended)

.babelrc

{
  "presets": ["es2015-mod"]
}

Via CLI

$ babel script.js --preset es2015-mod

Via Node API

require("babel-core").transform("code", {
  presets: ["es2015-mod"]
});

以上是 babel-preset-es2015-mod 的使用教程帮助文档。


上一篇:@egis/build-tools
下一篇:u-test
相关教程
关注微信

扫码加入 JavaScript 社区

相关文章

首次访问,需要验证
微信扫码,关注即可
(仅需验证一次)

欢迎加入 JavaScript 社区

号内回复关键字:

回到顶部